BGP Load Sharing When Multihomed to Two ISPs Through a Single Local Router

Описание к видео BGP Load Sharing When Multihomed to Two ISPs Through a Single Local Router

BGP Load Sharing When Multihomed to Two ISPs Through a Single Local Router

In this scenario, load balancing is not an option in a multi-homed environment, so you can only do load sharing.
You cannot do load balancing because BGP selects only a single best path to a destination among the BGP routes that are learned from the different ASs.
The idea is to set a better metric for the routes in the range 1.0.0.0 to 128.0.0.0 that are learned from ISP(A) and a better metric for the rest of the routes that are learned from ISP(B).
The Network Diagram is an example.

CONFIGURE:
Router_A:
conf t
interface g0/0
no shut
ip address 160.20.20.1 255.255.255.0
!
interface g0/1
no shut
ip address 150.10.10.1 255.255.255.0
!
router bgp 11
neighbor 160.20.20.2 remote-as 10
neighbor 160.20.20.2 route-map UPDATES-1 in

!--- This allows only the networks up to 128.0.0.0.

neighbor 150.10.10.2 remote-as 12
neighbor 150.10.10.2 route-map UPDATES-2 in

!--- This allows anything above the 128.0.0.0 network.

route-map UPDATES-1 permit 10
match ip address 1
set weight 100

route-map UPDATES-1 permit 20
match ip address 2

route-map UPDATES-2 permit 10
match ip address 1

route-map UPDATES-2 permit 20
match ip address 2
set weight 100

access-list 1 permit 0.0.0.0 127.255.255.255
access-list 2 deny 0.0.0.0 127.255.255.255
access-list 2 permit any
end
wr

Router_B:
conf t
interface Loopback0
ip address 2.2.2.2 255.255.255.0
int loopback 1
ip address 170.16.6.5 255.255.255.0

interface g0/0
no shut
ip address 160.20.20.2 255.255.255.0


router bgp 10
neighbor 160.20.20.1 remote-as 11
network 2.0.0.0
network 170.16.0.0
end
wr

Router_C:
conf t
interface Loopback0
ip address 170.16.6.6 255.255.255.0

interface Loopback1
ip address 2.2.2.1 255.255.255.0

interface g0/1
no shut
ip address 150.10.10.2 255.255.255.0


router bgp 12
neighbor 150.10.10.1 remote-as 11
network 2.0.0.0
network 170.16.0.0
end
wr


VERIFY:

show ip bgp
show ip route
traceroute 2.2.2.2
traceroute 170.16.6.6


🔔 Subscribe to my YouTube channel:
   / @ferdsthenetworkguy  

Facebook Page:   / ferdsthenetworkguy  

📺 Playlist of all my videos on BGP:
   • BGP  

Facabook Page:   / ferdsthenetworkguy  



References:
Load Sharing When Dual-Homed to One Internet Service Provider (ISP) Through a Single Local Router: https://www.cisco.com/c/en/us/support...
How Does Load Balancing Work?: https://www.cisco.com/c/en/us/support...
BGP Multipath: https://www.cisco.com/c/en/us/support...
BGP Best Path Selection Algorithm: https://www.cisco.com/c/en/us/support...

#cisco #bgp #ccna #ccnp #ccie

Комментарии

Информация по комментариям в разработке